He hablado anteriormente sobre cómo asegurar o fortificar WordPress de diferentes maneras, pero no siempre abordamos el tema de como solucionar o limpiar sitios web infectados principalmente con malware en WordPress y es de lo que queremos hablarte.

Es importante estar documentado y entender las diferentes vulnerabilidades que pueden afectar a tus instalaciones de WordPress. No hay ninguna regla radical y rápida que erradique vulnerabilidades, pero un conjunto de procedimientos y precauciones que se tomen como usuario o administrador de sitios web conducirán hacia un sistema más seguro.

Aunque WordPress es lo suficientemente bueno, si vienes de versiones anteriores entonces en determinadas ocasiones verás un mensaje diciendo que “hay una versión disponible” y que es bueno que actualices. Asegúrate siempre de que tu WordPress trabaja con la última versión disponible, ya que eso te librará de un 0-day. No obstante, si en algún momento obviaste la seguridad de WordPress, es posible que ya estés infectado y que incluso no lo sepas ¿quieres verificarlo?.

Para poder analizar el estado de salud de nuestras instalaciones de WordPress vamos a utilizar el plugin Anti-Malware and Brute-Force Security by ELI desarrollado por Eli Scheetz y enfocado en el análisis exhaustivo de los archivos de la instalación donde este se instale y detectar amenazas reconocidas o posibles patrones de amenazas no reconocidas oficialmente.

Este plugin ha sido creado para ayudar a los administradores de WordPress a limpiar infecciones en su sitio web. Fue inspirado en la necesidad de su autor por limpiar una de sus cuentas en BlueHost. El plugin se ofrece actualmente de forma totalmente gratuita, aunque sí puedes obtener algún “extra” haciendo un donativo para sostener el proyecto.

Características destacadas de Anti-Malware and Brute-Force Security:

  • Eliminación automática de “Amenazas conocidas”.
  • Si realizas una donación al autor podrás descargar definiciones de nuevas amenazas a medida que se descubren.
  • Actualiza de forma automática las versiones vulnerables del script TimThumb.
  • Parchea automáticamente wp-login.php para bloquear ataques de fuerza bruta.
  • Ejecuta un análisis rápido desde el menú de administración.
  • Es posible personalizar la configuración de escáner.
  • Es posible realizar un análisis completo desde la página de configuración.

He publicado una entrada completa que puedes consultar en el Blog de Webempresa, así que ¡si te apetece saber como acaba esta historia, no dudes en visitarla!.

Mis post en tu correo cuando se publiquen

Sin SPAM ¡Palabra!

Compartir es GRATIS ¿te animas?Tweet about this on TwitterShare on Google+2Share on Facebook0Pin on Pinterest0Email this to someone